Helpful information regarding Notes 9/Sametime 9 on Ubuntu 13.10 64bit

After fighting a bit again with IBM Notes 9 and Sametime Embedded 9 I have a few conclusions here

1) To install plugins using an updatesite

sudo chmod 777 -R /opt/ibm/notes/framework/*

— It seems permissions are set to tight to even install a dictionary. Why is it not installed in userland? I got provisioning error until I ran the command above. After provisioning is done and notes is restarted then do this: “sudo chmod 755 -R /opt/ibm/notes/framework/*”

2) To restart Notes use a kill script

Notes leaves processes running and refuse to restart – a bad habit, and here is the cure.

> cat noteskilllin.sh
ps aux | grep ibm | awk ‘{print $2}’ | xargs kill -9
ps aux | grep nsdexec | awk ‘{print $2}’ | xargs kill -9
ps aux | grep sametime_idlemon | awk ‘{print $2}’ | xargs kill -9
ps aux | grep sametime_mongss | awk ‘{print $2}’ | xargs kill -9

3) Here are the compatibility libraries for Notes 9 and Sametime 9 (remember you have to first hack the deb-files using instuctions found in earlier posts on this blog)

apt-get install libart-2.0-2:i386 libasound2:i386 libatk1.0-0:i386 libbonobo2-0:i386 libbonoboui2-0:i386 libc6:i386 libfontconfig1:i386 libfreetype6:i386 libgcc1:i386 libgconf2-4:i386 libgtk2.0-0:i386 libglib2.0-0:i386 libgnome2-0:i386 libgnomecanvas2-0:i386 libgnomeui-0:i386 libgnomevfs2-0:i386 libglib2.0-0:i386 libice6:i386 libjpeg62:i386 liborbit2:i386 libpam0g:i386 libpango1.0-0:i386 libpng12-0:i386 libpopt0:i386 libsm6:i386 libstdc++6:i386 libx11-6:i386 libxcursor1:i386 libxext6:i386 libxft2:i386 libxi6:i386 libxkbfile1:i386 libxml2:i386 libxp6:i386 libxrender1:i386 libxss1:i386 libxt6:i386 libxtst6:i386 libz1:i386  libz1:i386 gtk2-engines-murrine:i386 gtk2-engines-murrine murrine-themes  libgnomeprintui2.2-0:i386 libgnomeprint2.2-0:i386

4) I cannot get Sametime 9 to use Audio/Video and I cannot give out control in Instant Share

The Instant Share problem is well known and shared with Mac users, I hoped that they fixed it in version 9. But the Audio/Video-stuff is a bit saddening, have anybody got embedded Sametime 9 to work with Audio/Video?

Please share your experiences here or link to where other users share their experiences.

5) sametime-connect-embedded-9.0-20130911.1645.i386.deb and sametime-connect-embedded-core-9.0-20130911.1645.i386.deb

Why have IBM produced 2 packages for Sametime embedded install?

Sametime connect embedded control file:

Source: sametime-connect-embedded:
Section: IBM
Priority: extra
Maintainer: IBM Lotus Product <sw_support@us.ibm.com>
Package: sametime-connect-embedded
Architecture: i386
Installed-Size: 5000
Version: 9.0-20130911.1645
Depends: libx11-6, libxt6, libxext6, libc6, libgcc1, libgtk2.0-0, libxkbfile1, libglib2.0-0, libstdc++6, libjpeg62
Pre-Depends: bash, ibm-notes
Conflicts: sametime-connect-embedded-core, sametime-connect-embedded-ui, sametime-advanced-embedded
Replaces: sametime-connect-embedded-ui, sametime-connect-embedded-core, sametime-advanced-embedded
Description: IBM Sametime Connect Embedded
IBM Sametime embedded plugins for IBM Notes.

Sametime connect embedded core:

Source: sametime-connect-embedded-core
Section: IBM
Priority: extra
Maintainer: IBM Lotus Product <sw_support@us.ibm.com>
Package: sametime-connect-embedded-core
Architecture: i386
Installed-Size: 5000
Version: 9.0-20130911.1645
Depends: libx11-6, libxt6, libxext6, libc6, libgcc1, libgtk2.0-0, libxkbfile1, libglib2.0-0, libstdc++6, libjpeg62
Pre-Depends: bash, ibm-notes
Conflicts: sametime-connect-embedded
Replaces: sametime-connect-embedded
Description: IBM Sametime Connect Embedded
IBM Sametime connect embedded plugins for IBM Notes.  Notes cannot function without this core Sametime package.

I only installed sametime-connect-embedded

Advertisements

3 Responses to “Helpful information regarding Notes 9/Sametime 9 on Ubuntu 13.10 64bit”

  1. Rod Little Says:

    instant share, and ST meetings work for me once I roll back Java JRE to 1.6 or one of the previous 1.7 releases. Only thing not working for me is Video calls, as the image from my Web Cam is corrupted (web cam image is fine in other apps eg Cheese)

  2. marcos Says:

    It works, thank you very much. However, if you start notes from the command line you will still see the following error:

    p11-kit: couldn’t load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: no se puede abrir el archivo del objeto compartido: No existe el archivo o el directorio

    (can’t open the shared object file: file or directory do not exist)

    Not sure what the immediate effect of that error is. In any case, the error disappears if you add

    gnome-keyring:i386

    to the compatibility libs to install listed in step 3)

    • marcos Says:

      Unfortunately the error still does not completely disappear, but randomly pops up in console in a different form:

      p11-kit: couldn’t load module: /usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so: no se puede abrir el archivo del objeto compartido: No existe el archivo o el directorio

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: